Пожалуйста помогите решить задачу:

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

1

Ответы и объяснения

  • Участник Знаний
2012-06-13T15:28:56+00:00

Это Проверенный ответ

×
Проверенные ответы содержат надёжную, заслуживающую доверия информацию, оценённую командой экспертов. На "Знаниях" вы найдёте миллионы ответов, правильность которых подтвердили активные участники сообщества, но Проверенные ответы - это лучшие из лучших.

Примерно так. На псевдоязыке, который легко переводится в тот, который знаком

 

//*********************************************************

Сумм=0;

Конец=0;

 

Ввод(Ч);

Пока (Ч#Конец)  Цикл

        Если Проверить(Ч)=1 Тогда  

               Сумм=Сумм+Ч; 

       КонецЕсли;

      Ввод(Ч);

КонецЦикла;

 

Печать(Сумм);

//*****************************************************************

 

//******************************************************************

Функция Проверить(П)

       Если Остаток(П,10)=4 Тогда

                Если Остаток(П,6)=0 Тогда

                         Возврат(1);

                КонецЕсли;

       КонецЕсли;

       Возврат(0);

КонецФункции

//*******************************************************************

 

Этот текст не использует массивы, поэтому количество вводимых чисел неограничено. Их величина определяется описанием переменной(если в языке оно явно требуется, для приведенных данных достаточно описать как ЦЕЛОЕ(INTEGER)). Сумм описать побольше(если требуется).

Если в языке нет функции Остаток(обычно MOD), напиши свою, это очень просто.

Повторюсь, в Паскаль, Бейсик, 1С текст переводится очень легко, в С(Java, PHP и пр.) чуть сложнее, там немного другой синтаксис, но это преодолимые проблемы.