ПРОГРАММИРОВАНИЕ МАТРИЧНЫХ ОПЕРАЦИЙ
Разработать программу решения четырех взаимосвязанных задач частой работы:

1) расчета элементов квадратной матрицы A = (ai,j), i,j = 1,2,...,n по заданной формуле;

2) вычисления элементов вектора X = (xi), i = 1,2,...,n по заданному правилу;

3) требуемого упорядочения элементов матрицы А или вектора Х;

4) вычисления значения y по заданной формуле.

1) соотв фото 1

2)соотв фото 2

3) упорядочить элементы вектора Х по возра

станию абсолютных значений;

4)соотв фото 3

1

Ответы и объяснения

Лучший Ответ!
  • Участник Знаний
2012-05-30T15:43:46+00:00

В принципе, все эти задачи можно решить по одной схеме, например, такой. (Текст программы на некоем условном языке программирования(хотя он имеет РЕАЛЬНЫЙ аналог))

 

Для i = 1 по N Цикл

      Для j= 1 по М Цикл

            А[i,j]=МояФункция(i,j);  

      КонецЦикла;

КонецЦикла;

 

Вот и все.

 

 1. Текст функции будет

 

Функция МояФункция(а,б)

    Числитель    =(2*а + 3*б) * (2*а + 3*б);

     Знаменатель=(а + б +5)^(0.33333333333);

     Возврат(Числитель/Знаменатель);

КонецФункции

 

2. Чуть-чуть модифицировано

 

Для i = 1 по N Цикл

      X[i]=0;

      Для j= 1 по М Цикл

            X[i]=Макс(X[i],МояФункция(A[i,j]));  

      КонецЦикла;

КонецЦикла;

 

Функция МояФункция(а)

    Если а<=0 Тогда

          Возврат(0);

    Иначе

         Возврат(sqr(a));

     КонецЕсли;

КонецФункции

 

Примерно так же и остальное.

3. Упорядочивать проще всего по методу "пузырька", текст есть в любом букваре и практически не будет отличаться от приведенных двух решений, только функция будет сравнивать текущее и предыдущее значение и переставлять их.

 

4. То же самое, только цикл с шагом 2.

 

Замечание

 1. При решении постулировалось, что функции Макс, возведение в степень - встроенные функции языка. Если это не так, просто пишутся ПОЛЬЗОВАТЕЛЬСКИЕ функции с этими именами и реализующие необходимые функции.

 2. При программировании старайтесь как можно больше стандартизировать своё творчество, это значительно ускорит сам процесс, уменьшит количество ошибок и ... покажет взаимосвязь многих задач, алгоримов, подходов, подтверждающих, что МИР ЕДИН и нет ОТДЕЛЬНО физики, математики, химии, биологии, лингвистики, все эти науки просто с разных сторон описывают и изучают всё тот же ЕДИНЫЙ МИР, частью которого являемся и мы с вами.