Ответы и объяснения

2014-03-27T14:46:08+04:00
На каком языке программирования не написали.
алг Пароход;
   дано a, b, c :цел;
   рез к: цел;
нач
   ввод a, b, c;
   если (a+b) mod c=0 
          то к:=(a+b) div c
          иначе к:=((a+b) div c) +1
   всё;
   вывод к;
кон.
P.S  В общем смысл такой, если общее количество пассажиров и команды делится без остатка на с, то количество шлюпок равно количество пассажиров и команды делим на с. Если на делится без остатка, то добавляем ещё одну шлюпку на оставшихся пассажиров.