Ответы и объяснения

2014-03-26T07:28:40+04:00
Использовать Робот
алг
нач
. нц 7 раз
. . переход
. кц
кон
алг переход
нач
. закрасить
. вниз
. вправо
. закрасить
. вверх
. вправо
кон

неправильно, там стена
у меня робит и код не такой объмный
у тебя код большой и повторений много их можно было в процедуру сделать
а понял
;)
2014-03-26T12:47:43+04:00
 использовать Робот
алг квадрат
нач
влево
нц пока снизу стена
влево
закрасить
влево
кц
влево
вниз
вправо
нц пока сверху стена
вправо
закрасить
вправо
кц
кон