Ответы и объяснения

2014-03-17T18:13:02+04:00
 использовать Роботалг
 нач
нц пока не слева стена 
       закрасить
       влево
       влево
кц
       закрасить
нц пока снизу стена
   вправо
кц
нц пока не  сверху стена
   вверх 
кц 
    закрасить
    вниз
нц
пока не снизу стена
   если снизу стена  
      то   вверх
  иначе 
            вниз
       закрасить
       вниз
   все
кц
кон