1. Дана вещественная матрица размерности n * m. Удалить k столбец матрицы.

2
Комментарий удален
Комментарий удален
Комментарий удален

Ответы и объяснения

  • Участник Знаний
2014-01-08T22:06:00+04:00
Не указан язык. пример на псевдоязыке. Вариант 4

Массив А(м,н)
Массив Б(м,н-1)

Сформировать(А,Б);  // Это процедура которая как-то формирует исходные массивы
Прочитать(к); // Это процедура, которая откуда-то берёт к и проверяет его на корректность

Для стр=1 по м Цикл
     Для стлб=1 по к-1 Цикл
          Б(стр,стлб)=А(стр,стлб);
     КонецЦикла;
     Для стлб=к+1 по н Цикл
         Б(стр,стлб-1)=А(стр,стлб);
     КонецЦикла;
КонецЦикла; 

Ну где-то так

  • Sky09
  • профессор
2014-01-09T00:06:03+04:00
У меня работа с одним массивом.
Паскаль.
---
uses crt;
const N=4;
        M=6;
var a: array [1..n,1..m] of integer;
    x,y,k,p: integer;
begin
     for x:=1 to n do begin
         for y:=1 to m do begin
             a[x,y]:=random(21)-10;
             write(a[x,y]:4);
         end;
         writeln;
     end;
     write('k='); readln(k);
     if k<=m then p:=m-1 else p:=m;
     for y:=k+1 to m do
          for x:=1 to n do
             a[x,y-1]:=a[x,y];
     for x:=1 to n do begin
         for y:=1 to p do
             write(a[x,y]:4);
         writeln;
     end;
end.
VAR
n,m,k,i,j:Integer;
a: Array of Array of Integer;
BEGIN
Read(n, m, k);
SetLength(a, n+1); For i := 1 to n do SetLength(a[i], m+1);

For i := 1 to n do
For j := 1 to m do
Read(a[i][j]);

For i := 1 to n do
For j := k to (m - 1) do
a[i][j] := a[i][j+1];

// Рамерность массива - N*M => N*(M-1)
// For i := 1 to n do SetLength(a[i], m);

For i := 1 to n do begin
For j := 1 to (m-1) do Write(a[i][j], ' ');
Writeln; End;
END.