Определите значение целочисленной переменной S после выполнения операторов:в) S:=1; a:=1 нц для i от 1 до 3 S := S+i нц для j oт 2 до 3 S := S+j кц кц

2

Ответы и объяснения

  • Sky09
  • профессор
2013-06-23T18:19:34+00:00

Для чего там переменная а?

---

S:=1;

a:=1

нц

  для i от 1 до 3

    S := S+i {В этом цикле мы получаем значения S:2->4->7}

  нц

    для j oт 2 до 3

      S := S+j {В этом цикле мы получаем значения S:9->12}

  кц

кц

 

Таким образом, после выполнения операторов переменная S будет равна 12

2013-06-23T19:27:02+00:00

Это Проверенный ответ

×
Проверенные ответы содержат надёжную, заслуживающую доверия информацию, оценённую командой экспертов. На "Знаниях" вы найдёте миллионы ответов, правильность которых подтвердили активные участники сообщества, но Проверенные ответы - это лучшие из лучших.

сначала S = 1
далее цикл по i:
i=1    S=1+1=2
i=2    S=2+2=4
i=3    S=4+3=7
далее цикл по j:
j=2    S=7+2=9
j=3    S=9+3=12

 

Ответ: 12