Пожалуйста, помогите сделать Робота!

На бесконечном поле клеток находится замкнутая по горизонтали комната произвольной длины и высоты. Робот расположен непосредственно под верхней стеной. Возможная начальная позиция Робота отмечена на рисунке буквой Р.Напишите для Робота алгоритм, рисующий ломаную линию от левого нижнего угла комнаты. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведенного выше рисунка Робот должен закрасить следующие клетки(на рисунке изображено).

Конечное положение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера стен и любой допустимой начальной позиции Робота.

1

Ответы и объяснения

  • nemp
  • хорошист
2013-05-16T12:51:49+00:00

алг

  нач

  нц пока слева свободно

   влево

кц

 нц пока снизу свободно

вниз

кц

нц пока справа свободно

  нц пока (сверху свободно) и (справа свободно)

    вправо

    вверх
    закрасить

кц

нц пока (снизу свободно) и (справа свободно)

    вправо

    вниз
    закрасить

кц

кон