Дано трехзначное число N. Проверить, будет ли сумма его цифр четным числом. Кто может, напишите пожалуйста алгоритм решения для программы Кумир.

1

Ответы и объяснения

2013-05-14T20:02:06+04:00

алг

нач цел a,n

ввод n

a:=0

нц пока n>0

a:=a+mod(n,10)

n:=div(n,10)

кц

вывод "Сумма цифр числа = ", a

если mod(a,2) = 0

то

вывод "Сумма цифр числа четная"

иначе

вывод " cумма цифр числа нечетная"

все

кон