Составте алгоритм нахождения наименьшего из трех значений.Помогитеееееееееее!

1

Ответы и объяснения

  • Участник Знаний
2013-04-17T22:04:50+04:00

Допустим, в языке есть встроенная функция

Min(a,b) которая определяет мин из двух значений. Тогда алгоритм выглядит так

 

х=Мin(a,b);

x=Min(x,c); 

 

А если нужно найти мин из N чисел, которые запрятаны в массив А(n), то так

 

x=999999999999999999999; // какое-то ОЧЕНЬ большое число

 

Для ц=1 по N цикл

       x = Min(x,A(ц));

КонецЦикла;

 

А что, если такой функции в языке нет, спросишь ты, тогда её нужно написать самому, например, так

 

Функция Min(a,b)

    Если a<b Тогда

          Возврат(а);

    Иначе

          Возврат(b);

     КонецЕсли;

КонецФункции

 

Вот и всЁ! Учитесь мыслить алгоритмически структурно, разбивая сложный алгоритм на ряд простых и понятных, и всё будет очень просто.

Успехов!